Server Maintenance Monday Night
Incident Report for QuickFlora
Resolved
We are done with server maintenance. System is working fine.
Posted May 22, 2018 - 05:36 EDT
Update
We have started Server Maintenance activity.
Posted May 22, 2018 - 02:20 EDT
Investigating
NOTE: We will starting server maintenance tonight at 9PM PST (Midnight EST) for up to six hours to upgrade to new faster servers. The system will be offline during this time and resume normal operations early Tuesday morning.

You can check the system status at https://quickflora.statuspage.io


The Support Team at QuickFlora
Posted May 22, 2018 - 02:20 EDT
This incident affected: QF DC1 POS Users.