QuickFlora Temporary Service Disruption - Updates to Follow

Incident Report for QuickFlora Server Status Page

Resolved

We have resolved the issue. All functions are now operational and working properly.
Posted Aug 26, 2026 - 09:42 EDT

Investigating

We are currently experiencing technical difficulties affecting our server. We are aware of the issues and our team is actively working to resolve it.
Posted Aug 26, 2026 - 08:51 EDT
This incident affected: QF DC1 POS Users.