Server Maintenance
Incident Report for QuickFlora
Resolved
This incident has been resolved.
Posted Apr 22, 2019 - 01:10 EDT
Investigating
We are performing regular Server Maintenance to improve the performance. Some of the QuickFlora functions may not work in this period. We will be back within 60 minutes.
Posted Apr 22, 2019 - 00:30 EDT
This incident affected: QF DC1 POS Users.